Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Loading units for transport not working well with "Individual Initiative" rule
First off, I would like to express my extreme gratitude to all the devs involved in keeping megamek (and especially MekHQ) going.

I've been running a lengthy campaign with my group for years and we really enjoy the added benefits of the Individual Initiative rule.

Unfortunately, I've run into some trouble with it when trying to load infantry onto an APC (i assume the same problem exists for dropships).

If the APC has to move BEFORE the infantry, there is no issue.  However, if the APC moves AFTER the infantry, I've found no way to load the infantry onto the APC... even if both begin the turn in the same hex.  Currently I'm forced to have both units remain sitting in the same hex.  This can be somewhat controlled by giving APCs a worse Initiative bonus than the infantry, but this is at best only a partial workaround and less than ideal for when things are actively shooting at them.

But it gets weirder...

Assuming the infantry moves first, they cannot load onto the APC so I hit "Move" without expending MP; effectively ending their turn where they started.  I then switch to the APC and find that the "Load" button DOES light up, but when I click on it, nothing happens.  The blue text saying "Load" that usually shows up in the hex (when you successfully load a unit) doesn't pop up. 

It looks like the APC is trying to load the infantry but can't for whatever reason (my guess is because the infantry have already finished their movement).

Any thoughts?  Ideally, I would think that if megamek checks to see that both the APC and infantry have not expended any MPs, the APC should be allowed to "Load" the infantry regardless of if the infantry's movement phase happened first or not.

EDIT: I'm using 0.39.1-dev-r11018  because that came with the last "stable" MekHQ build to my knowledge... although now that I think about it... might be time for me to update that.  With any luck, maybe you guys already fixed this. Smile
How about using the unofficial rule 'infantry move after all other units'? It might work.
(07-20-2015, 08:44 PM)SirMegaV link Wrote:How about using the unofficial rule 'infantry move after all other units'? It might work.
That would be a decent solution if it worked (not sure it would fix loading on dropships, though), but sadly... doesn't seem to be compatible with Individual Initiative.  The rule seems to force everything into strictly following whatever resulted from initiative rolls... which isn't a terrible thing by itself, but as already mentioned above, definitely screws with two units trying to interact with each other.
Could anyone else weigh in on this?  I'm curious to know if this is a known issue, something being worked on, etc.
Not really an issue. Just that individual initiative overwrites other movement options. It was discussed on another post.

Possibly Related Threads…
Thread Author Replies Views Last Post
  Individual Initative & Ejection? Scia 7 888 01-13-2017, 05:22 PM
Last Post: Scia
  Teams Roll Initiative Doesn't seem to be working grimlock 2 738 12-21-2014, 11:27 AM
Last Post: Arlith
  Individual Initiative + Tactical Genius? luiges90 7 2,155 03-29-2014, 12:13 AM
Last Post: Xenon54z
  Hangs Loading Units (unplayable) just1chancefree 27 6,268 05-15-2013, 11:07 PM
Last Post: Xenon54z
  Bug with tac ops rule : Additional PSRs for damage? Question2 3 1,085 04-30-2012, 04:56 PM
Last Post: Xenon54z

Forum Jump:

Users browsing this thread: 1 Guest(s)