Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Hangs at "Waiting for server" when starting a scenario.
My MegaMek works fine when opening directly and setting up a game.

However, ever since updating to the latest MekHQ, when I attempt to start a scenario from MekHQ it opens MegaMek, then hangs on "waiting for server" interminably.

I've tried using older Java builds all the way back to 8u20 (currently 8u66).  I get the same problem on my desktop, and both laptops running Win7, Win8, and Win 10.

Here's my MekHQ log dump:

s: starting a new server...
s: hostname = 'AKIP-TCHP97' port = 2346
s: hosting on address =
s: hosting on address = fe80:0:0:0:98ee:c5a2:efa5:5db2%15
s: password = null
s: listening for clients...
Parsing defaultKeyBinds.xml
Parsing finished.
Total number of key binds parsed: 25
Loading more unit images from localserver_mechset.txt...
Loading more unit images from localclient_mechset.txt...
... finished localclient_mechset.txt.
... finished localserver_mechset.txt.
Loading more unit images from localclient_wreckset.txt...
... finished localclient_wreckset.txt.
hexTileset: loaded 163 base images
hexTileset: loaded 1874 super images
hexTileset: loaded 64 ortho images
Parsing defaultSkin.xml
Parsing finished.
s: accepting player connection #0 ...
s: player #0, The Long War connected from /
SUCCESS: Client/Server Version (0.41.13) and Checksum (f6a407c54ff80357a29ff37bd30d9cf549271dd233b92d0682d40027099af055) matched
Thread in lounge
MMRandom: generating RNG type #1
Tried to load camo that doesn't exist: p0procks High Quality/GrimFire.jpg
Exception in thread "AWT-EventQueue-0" java.lang.IllegalArgumentException: Row index out of range
at javax.swing.JTable.boundRow(Unknown Source)
at javax.swing.JTable.setRowSelectionInterval(Unknown Source)
at megamek.client.ui.swing.CamoChoiceDialog.setPlayer(
at megamek.client.ui.swing.ChatLounge.refreshCamos(
at megamek.client.ui.swing.ChatLounge.setupPlayerInfo(
at megamek.client.ui.swing.ChatLounge.<init>(
at megamek.client.ui.swing.ClientGUI.initializePanel(
at megamek.client.ui.swing.ClientGUI.switchPanel(
at megamek.client.ui.swing.ClientGUI$5.gamePhaseChange(
at megamek.common.event.GamePhaseChangeEvent.fireEvent(
at megamek.common.Game.processGameEvent(
at megamek.common.Game.setPhase(
at megamek.client.Client.changePhase(
at megamek.client.Client.handlePacket(
at megamek.client.Client$1$
at java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
at java.awt.EventQueue.access$500(Unknown Source)
at java.awt.EventQueue$ Source)
at java.awt.EventQueue$ Source)
at Method)
at$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at Source)
Can you attach the full MekHQlog.txt file.

(01-05-2016, 11:15 AM)Hammer link Wrote: Can you attach the full MekHQlog.txt file.

From a different computer, but has the same issue.  I haven't updated to 3.23 (using 3.21) on this PC, yet either.

And i suppose i should have put this in the Support forum.  I apologize, I saw this forum first and went with it.

Attached Files
.txt   mekhqlog.txt (Size: 100.1 KB / Downloads: 0)
If I recall 3.21 had that bug and it was fixed for 3.23
(01-05-2016, 09:01 PM)Hammer link Wrote: If I recall 3.21 had that bug and it was fixed for 3.23

It does it with 3.23 on my laptop.

Installing it on my desktop now and trying it.
Ok, this is with 3.23 and Java 8u66.  Getting the same issue.

Attached Files
.txt   mekhqlog.txt (Size: 190.38 KB / Downloads: 1)
Not one of the coding devs...but look like its crashing after trying to load a camo pattern.  The p0procks camo patterns aren't included in the official releases.

In the past where you using one of the Ralgith Custom releases?  If so you would need to move the camo's over and try it again.

If you zip up your campaign and any custom units we can test some other things.
Ok, I'll try that when I get home from work today, and zip up my campaign.  Thanks for the responses so far!
It was the camo.  I had moved it over, but the directory was different so it couldn't find it.

I feel...not very bright at the moment, lol.  thanks for all your help!
No worries.  Should let you know these forums are pretty dead.  Most people use the MegaMek forums at the Catalyst Official site.

If you aren't already on that site I'd suggest heading over there:


Forum Jump:

Users browsing this thread: 1 Guest(s)