Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Targeting info not displayed in firing phase when selecting different weapons
#1
Hi. I don't know if this is a bug, but during the firing phase, switching between weapons causes the to-hit % and other targeting information to no longer be displayed.

Let's say we are targeting an enemy "X" and we have weapons "A" and "B" (in that order from top to bottom). When our unit gets its chance to fire, enemy X is targeted and the weapon to be fired first defaults to A. However, if we click on weapon B--perhaps I want to fire weapon B before A or fire weapon B without firing weapon A--the targeting info for weapon B on enemy X is not displayed. Currently, in order to work around that problem, we need to click on enemy X again after selecting weapon B in order for the targeting info to be displayed.

I'm using version 0.41.15, which I believe is the most recent version.

Edit: Oh and for the title of the latest post on the megamek homepage

new MegaMek development snapshot 0.41.15, MegaMekLab development snapshot 0.1.51, and MekHQ development snapsh*t 0.3.25

----- new MegaMek development snapshot 0.41.15, MegaMekLab development snapshot 0.1.51, and MekHQ development snapshot 0.3.25

Wink
Reply
#2
After something like this occurs, try looking in the logs/megameklog.txt file and see if there are any errors.  Generally when something like this happens it's because of an uncaught exception. This sounds like strange behavior, so I'd expect some type of bug.  If you have a saved game where it's reliably reproduceable, then getting us the saved game could also help figure out (and fix) the problem.
Reply
#3
There aren't any errors. This has been the way it works for quite awhile really.

IIRC since custom weapon order?
Reply
#4
Thanks for the replies. I haven't been able to reproduce the problem (tried playing with custom weapon order but everything worked fine this time) but if it pops up again I'll check the log for errors.
Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Princess Doesn't "Done" At Heat phase of first Round JIMLL565 7 1,588 08-26-2014, 09:28 AM
Last Post: JIMLL565
  Waiting for firing phase bug Madcow9000 5 1,807 09-29-2012, 12:06 PM
Last Post: Taharqa
  Lost all my info! Widowmaker 2 993 08-20-2012, 12:03 PM
Last Post: Xenon54z
  Game keeps crashing at end of firing phase. Question2 3 1,718 04-20-2012, 12:42 PM
Last Post: Question2
  Major bug during movement phase - More button is missing, replaced by... ralgith 4 1,207 03-13-2012, 07:39 PM
Last Post: BeeRockxs
  Swarm LRMs and Point-Blank Range Targeting Candidates BATTLEMASTER 0 1,069 03-05-2011, 12:29 AM
Last Post: BATTLEMASTER

Forum Jump:


Users browsing this thread: 1 Guest(s)