Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Megamek 0.40.1and Megamek Lab 0.1.50 will not launch
#1
I tried to run megamek tonight and most tragically it would not run.  The error message I received was:

"Launch4j
The registry refers to a nonexistent java runtime environment installation or the runtime is corrupted.

the system cannot find the file specified"

What is wrong as the program worked about a week ago?


My DXDIAG
System Information
------------------
Time of this report: 7/27/2016, 23:00:20
      Machine name: RATTLER-PC
  Operating System: Windows 7 Home Premium 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.150525-0603)
          Language: English (Regional Setting: English)
System Manufacturer: Gigabyte Technology Co., Ltd.
      System Model: M68MT-S2
              BIOS: Award Modular BIOS v6.00PG
          Processor: AMD FX™-6100 Six-Core Processor              (6 CPUs), ~3.3GHz
            Memory: 8192MB RAM
Available OS Memory: 8190MB RAM
          Page File: 3503MB used, 12875MB available
        Windows Dir: C:\Windows
    DirectX Version: DirectX 11
DX Setup Parameters: Not found
  User DPI Setting: 96 DPI (100 percent)
System DPI Setting: 96 DPI (100 percent)
    DWM DPI Scaling: Disabled
    DxDiag Version: 6.01.7601.17514 32bit Unicode

------------
DxDiag Notes
------------
      Display Tab 1: No problems found.
        Sound Tab 1: No problems found.
          Input Tab: No problems found.

--------------------
DirectX Debug Levels
--------------------
Direct3D:    0/4 (retail)
DirectDraw:  0/4 (retail)
DirectInput: 0/5 (retail)
DirectMusic: 0/5 (retail)
DirectPlay:  0/9 (retail)
DirectSound: 0/5 (retail)
DirectShow:  0/6 (retail)

---------------
Display Devices
---------------
          Card name: NVIDIA GeForce GTX 750 Ti
      Manufacturer: NVIDIA
          Chip type: GeForce GTX 750 Ti
          DAC type: Integrated RAMDAC
        Device Key: Enum\PCI\VEN_10DE&DEV_1380&SUBSYS_37573842&REV_A2
    Display Memory: 4040 MB
  Dedicated Memory: 1992 MB
      Shared Memory: 2048 MB
      Current Mode: 1920 x 1080 (32 bit) (60Hz)
      Monitor Name: Generic PnP Monitor
      Monitor Model: VX228
        Monitor Id: ACI22C1
        Native Mode: 1920 x 1080(p) (60.000Hz)
        Output Type: HDMI
        Driver Name: nvd3dumx.dll,nvwgf2umx.dll,nvwgf2umx.dll,nvd3dum,nvwgf2um,nvwgf2um
Driver File Version: 10.18.0013.6175 (English)
    Driver Version: 10.18.13.6175
        DDI Version: 11
      Driver Model: WDDM 1.1
  Driver Attributes: Final Retail
  Driver Date/Size: 1/22/2016 20:42:25, 16995064 bytes
        WHQL Logo'd: Yes
    WHQL Date Stamp:
  Device Identifier: {D7B71E3E-50C0-11CF-ED43-5A171FC2C735}
          Vendor ID: 0x10DE
          Device ID: 0x1380
          SubSys ID: 0x37573842
        Revision ID: 0x00A2
Driver Strong Name: oem89.inf:NVIDIA_Devices.NTamd64.6.1:Section130:10.18.13.6175:pci\ven_10de&dev_1380
    Rank Of Driver: 00E62001
        Video Accel:


Thank you.
Reply
#2
This recently happened to another player after a Java update.  He fixed it by uninstalling and reinstalling Java.  Seems like a current update may have problems.

Essentially, what the error is saying is that your windows registry is pointing to a java.exe file, however that file either doesn't exist, or it's broken.  In any case, a reinstallation would be the easiest way to fix it.
Reply
#3
It worked, thank you.
Reply
#4
Glad that worked.  But if your using 40.1 thats the old stable the dev releases are pretty stable and have tons on new features and other bug fixes.
Reply
#5
Just wanted to point out I had this same issue with the newest stable releases .42 and reinstalling java worked for it as well.

Thanks for the advise and post.

Sorry for the necro bump.
Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Special Mission - Civilian Help won't launch Jingo 1 250 03-23-2019, 07:25 AM
Last Post: Hammer

Forum Jump:


Users browsing this thread: 1 Guest(s)