Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
horrible UI tearing
a friend of mine has had this problem before in the past, but now it's happening to me. with the latest version of java (clean install after uninstalling and cleaning from registry) the game's interface 'tears' randomly into a bunch of images of itself, making the game nigh unplayable.

mekHQ does it also, and it's arguably worse because i don't know the UI there as well as i do megamek's

after searching for a little bit i've found no other reports of the problem so maybe i'm totally alone out here.

it happens on both the stable and developmental version of both mekHQ and megamek. pls help.

Attached Files Thumbnail(s)
We've had another recent report of this.  The bug report is here - MekHQ screen cascading

Not sure if anything there will help.
unfortunately he wasn't exactly specific in what he removed.

i've reinstalled my video drivers, java etc a few times now and undergone a few restarts and no dice. for whatever reason it seems to start once dropdowns are accessed, i can load 50 units, create a large map and move stuff around with no problems, but the second i touch a dropdown to add a bot it breaks.

earlier i was playing with a friend of mine and had the problem then too, but i have no idea why.

i hope i can figure it out, i really like the game but it's essentially unplayable and the aforementioned friend with this problem has had it for literal years and it's never been resolved.

You're on windows, yes?
7, yep.
alright, fixed it; for future readers that may have this problem, the issue is the AMD video recording software "playstv" installed automatically along with the drivers of most modern AMD cards. i found it while disabling random programs to see if it fixes it. all you have to do is disable the program while playing megamek and it works flawlessly again.

my friend doesn't have this program, but uninstalling his video drivers fixed the problem for him too, so there must be some bundled software with older versions causing problems. once we figure it out for his (significantly older) card i'll update this post with the solution for posterity.

wew lad
Thanks for the information.  This is a difficult issue to track down and fix.
I'm actually having this issue as well.

I have an AMD card and tried to turn off the playsTV thing as the previous poster mentioned, but that didn't actually work for me.

Not sure what else I can do at this point.

Attached Files Thumbnail(s)
what card do you have? i pretty much guarantee it's some of the bundled software that's doing it. try uninstalling your video drivers and running the game. if it works then, re-install them and do a minimal install (without most of the extraneous stuff, just the drivers themselves) then check the task manager's process tabs to make sure no AMD stuff is running and give it a try.
I have an R390.

So I uninstalled everything I could find AMD related, restarted, and tried the game. Worked fine, to my surprise.

Then I reinstalled literally nothing but the AMD display driver, and it's happening again. So the driver itself has to be the issue, at least for me.

Can't think of a better way to play the game than to uninstall the drivers every time I want to play.
ah, i have the 390 too. bizarre.

so it should be the same problem unless something else really strange is going on. are you sure you don't have playstv running? it probably doesn't show up as AMD. check your system tray.

also out of curiosity what driver version# are you running? i'm on 16.7.3 as of yesterday and as long as i don't run playstv it runs 100% perfectly.
It's definitely not running, double checked just in case. I'm running version 16.8.2.
for reference my playstv folder is in C:\program files\raptrinc\playstv. if you have that folder, try uninstalling it or deleting it if possible, if not, try reverting to my driver version (?) if it still doesn't work then it's obvious that something very bizarre is currently occurring.
Well after uninstalling everything I could find besides the drivers itself it seems to work, so thanks for the help! Stupid bloatware.
well, the program itself is actually pretty nice if you want to record game footage in 3d applications

as to why megamek and it do not get along, who knows  :Smile
Its not an issue with MegaMek or MekHQ but an issue with Java and ATI. MM/HQ don't use any special graphics calls beyond what is already in Java. There has been a long standing issue with various video drivers and OpenGL under windows though you usually only see it with low end cards such as the Intel onboard video a lot of motherboards have. Good to know you found and fixed the problem though  Smile
I just posted a topic with the exact same issue.  I have an NVidia card and the "tearing" or "glitching" would occur any time I would choose the dropdown list in the unit selection screen to select Princess.

I found that I had to enter the flag
javaw -Xmx1200m -Dsun.java2d.d3d=false -jar MegaMek.jar
into the megamek.l2j.ini file and my problems went away.

Forum Jump:

Users browsing this thread: 1 Guest(s)