Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Unit returns from battle as lost, pilot dies.
#1
I've a Samurai SL-25 Aerospace Fighter that, whenever I send it into battle, it returns dead, taking the pilot with it.
This has happened time and time again, even when I set the fighter and pilot to "not lost/Undamaged" and "0 wounds" respectively.
Oddly enough, when I do this, I keep the fighter but not the pilot.

I've taken to calling it "coffin" and giving it a new black and red paint scheme.
Any idea what could be causing this?
Reply
#2
What version are you using.
Reply
#3
(05-15-2017, 10:06 AM)Hammer Wrote: What version are you using.
MekHQ and MegaMek Version 0.43.2-git
Do you want me to send a save, .mul and salvage file?
Reply
#4
Your best bet would be to open a bug report on the MekHQ tracker (link in my sig). Attached the files their.
Reply
#5
(05-15-2017, 10:50 AM)Hammer Wrote: Your best bet would be to open a bug report on the MekHQ tracker (link in my sig). Attached the files there.

Will do, thanks!
Reply
#6
(05-15-2017, 10:53 AM)GraalOtonami Wrote:
(05-15-2017, 10:50 AM)Hammer Wrote: Your best bet would be to open a bug report on the MekHQ tracker (link in my sig). Attached the files there.

Will do, thanks!
I totally forgot about this and I meant to post it.
I found the issue, MegaMek was invalidating the unit, thus not fielding it. As a result, the mission ended with it as a "total loss", and the pilot as "dead".
I'm pretty sure it was something like the SL-5 or something, but I'll try it out again tomorrow to see if it works. Oddly, I had the same issue with one of the Marauders, so i refitted it, that worked.
Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Battle information not transferring to mekhq after the battle saracen 14 3,053 02-15-2012, 09:33 PM
Last Post: saracen

Forum Jump:


Users browsing this thread: 1 Guest(s)