Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
issue with MegaMek and Java

i downloaded Megamek version 0.44.0 last night.
but when i tried to open the EXE file, i got the following error:
is my version of java too old or is there some sort of config that i need to edit
i am using Windows XP Professional SP3 with Java Standard Enviroment 7 update 75
I would upgrade to Java 8. Also make sure Java is added to Windows Path Statement
i have already tried to upgrade to java 8. but java 8 does not support windows XP.
Oh! That is an issue. Correct me if I'm wrong, but Windows XP isn't supported anymore either, so that won't help. You could always try finding an older version of MegaMek that runs on Java 7. But that isn't the most optimal solution.

So, if you feel like you are tech savvy enough, try a Linux distro like Ubuntu or Lubuntu for a free new operating system. Ubuntu is easy to install most of the time, and Lubuntu is a lite version of it for really old hardware. The good thing is that they both support Java 8. You can find guides on installing any Linux distro at their websites and most have pretty good communities to ask questions with. Just BACK UP your stuff before you do. You'll most likely have to clear the hard drive during installation to get rid of Windows.

I think those are really your only two options but I'll let other chime in, too. I'm no expert. Smile
According to the Java site you should be able to install Java 8 If you google installing Java 8 on Windows XP their are quite a few videos and step by steps available.
then someone at oracle doesn't know what they are talking about. because these are the supported Windows operating systems listed for Java 8
neither the online or the offline installer for java 8 will run on my xp.

i have used Lubuntu before and it is indeed a good Linux distro.
However, i don't want to replace my XP install. i still use XP for tons of stuff and i will continue to use it until this computer is broken beyond repair.
and sadly i don't have enough room on the HDD to setup a linux partition for a dual boot.
i do have a win 7 PC, but it needs a new PSU before i can use it again.

i know that this all sounds like alot of "nay" saying, but this is my situation.
if i am able to find a way to run MegaMek with my current setup. i will let you know
thank you for your help. Smile

Possibly Related Threads…
Thread Author Replies Views Last Post
  MegaMek on Windows issue MadCartographer 2 633 04-18-2019, 01:04 PM
Last Post: MadCartographer
  MegaMek on Mac Issue RexCalices 6 1,007 05-18-2018, 10:46 AM
Last Post: Hammer
  Ubuntu Java Issue mpaluszk 4 1,777 10-03-2011, 01:20 PM
Last Post: ralgith

Forum Jump:

Users browsing this thread: 1 Guest(s)