Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
V0.46.0 Modifications to mech sprites don't show up in-game
#1
Version: 0.46.0
MekHQ (Downloaded from your homepage)
OS: Windows 7 Pro
Java version 1.8.0_211

Hey guys,

So I just tried changing some of the mech sprites in photoshop. Did my changes, saved in .png over the original mech. Looked at it in the C:\Program Files (x86)\mekhq-windows-0.46.0\data\images\units\mechs folder, everything looked good.

But then I load up MekHQ and start a new campaign but when I go to add the Mech to my roster it shows the original sprite, despite me having over-written it.

So what did I miss?
Reply
#2
Did the name change on the renamed file? Did the transparency stay or did it switch to a different background. The best thing to do would be to post the file here.
Reply
#3
(09-03-2019, 09:58 AM)Hammer Wrote: Did the name change on the renamed file?  Did the transparency stay or did it switch to a different background.  The fix thing to do would be to post the file here.

I'm pretty sure not, I checked the text file that lists the renames, it's the timberwolf and I didn't see it in there. The transparency stayed I think.

Here's the .png.


Attached Files
.png   Mad Cat (Timber Wolf).png (Size: 7.66 KB / Downloads: 26)
Reply
#4
An update.

So I've found that if I change the name of the .png and the name in mechset.txt the custom sprite will show up in game, but for some reason if my custom sprite just replaces the original sprite, only the original will show in game.

Anyone got ideas why that would be? Is there some fancy zip file (like a .pak ect) that the game checks first that I need to unpack and replace the original in there too?
Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Post game salvage/prisoners didn't show up.Mek HQ 0.44 arcweid 2 153 07-23-2018, 05:18 PM
Last Post: arcweid

Forum Jump:


Users browsing this thread: 1 Guest(s)