Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
"Connect to Game" window bugged
In MekHQ, whenever I go to the Briefing Room, select my Scenario, then "Join Game", the normal dialog box with 3 blanks in it has truncated blanks.  Looks like this:

[Image: 5A219309B22DB50381773057B081AF0CC6DA2865]

By contrast, the dialog for "Start Game" looks normal, as does "Load Save Game".  I am able to click within these blanks and use keyboard commands (End, Home) and type away, but of course I cannot see what is in that blank.  If I do it right, albeit blind, and then hit Okay, I can still connect.  It's just the display length of those fields that is truncated.

I looked for any mention of this here (,  but at least with the keywords I used, I didn't find anything.  Any advice?  Perhaps something I need to edit in a config file to get the window to expand out?  I tried grabbing it on the edges with the mouse, to resize it, and it will not "grab".

  • What version of program does your issue apply to?   MMHQ v0.46.1 Stable

  • Is this the version of Megamek that comes with MekHQ or the stand alone?  Not stand alone.

  • What operating system are you using?  Windows, Mac, or Linux?  Win10

  • What java version are you using?  Java version 1.8.0_261
Well... I worked around the problem by renaming my current mmconf to mmconf.corrupted, then unzipping the original mmconf folder from the original download.  That confirms that it is a config file issue somewhere, though I am not sure where exactly.  My best guess is the mekhq.preferences file, though I am not sure which dialog pertains to this window.

And I'm not sure how the issue started to begin with.  Hopefully it does not recur!
Okay.  We had this bug return, and I have narrowed it down to the mekhq.preferences file.  We unintentionally duplicated the bug by: loaded a Preset (that I configured and saved from my own settings), that I distributed to my friend's computer.  He loaded the preset.  It was sometime after this point, when we were ready, with identical Campaign settings set, to launch a Scenario for our campaign.  And we saw it hit again.

If I copy the version of this file that ships with the current HQ 0.46.1 and overwrite the one on a computer whose 0.46.1 MekHQ is misbehaving in this way, it clears the issue up.

Something about either the "Load a Preset" function, or a problem with how this version of MekHQ saves the Preset file, is causing the mekhq.preferences file to get mangled.  I am not technical enough to understand beyond that point, unfortunately, though I am willing to discuss and share samples as needed with someone who is.
This should be reported on a tracker, it will get missed on the forums. Links in my sig.
Thanks, I'm new to how best you guys want to do this.  Posted the bug here:

Possibly Related Threads…
Thread Author Replies Views Last Post
  Other players cannot connect to me Hakkonen 1 140 05-23-2020, 08:13 PM
Last Post: rjhancock
  MekHQ Window Size valmarus 3 983 06-30-2019, 11:45 AM
Last Post: Hammer
  Other people can't connect to your server? Read here. BeeRockxs 26 13,879 06-24-2018, 03:48 PM
Last Post: Hammer
  Not letting my connect when i start game theskullking 3 1,335 09-24-2013, 09:54 AM
Last Post: theskullking
  Error, could not connect to server bento 1 1,338 03-05-2012, 12:09 PM
Last Post: ralgith
  Other cant connect Grosnounou 15 4,230 01-24-2012, 11:24 PM
Last Post: Xenon54z
  Can't Connect Online Sandstorm 2 2,450 02-23-2011, 05:45 PM
Last Post: Taharqa

Forum Jump:

Users browsing this thread: 1 Guest(s)