Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Unable to save campaign in v0.1.10
#1
Downloaded the new version last night, ran into an "interesting" (frustrating) error; quickly jumped in and built a mixed mech/armor reinforced company, saved the file (both as the .cpmx and as an .xml), and closed; when I tried to open either file, it failed, because the savegame writer stopped writing halfway through. It just cuts off in the middle of a line in both savefiles. This is repeatable for me, since I built another unit earlier this morning, tried to save it, and again got half a savefile whenever I tried to save. Any idea what's going on here?
Reply
#2
Not yet, but Taharqa is looking into it. I ran into the same issue with a unit I loaded, added a few hired hands, advanced day and saved. The save seems to have cut off early and so it doesn't load as a result as you said.

Oddly enough saving has worked for many of my other units. I'll update when I find out more.
Reply
#3
I had the same issue.  What is odd as I was working on it last night, saved and closed it when I went to eat dinner and when I came back after it loaded fine. Now this morning it's giving me the unable to load message.
Reply
#4
Yes, I have JayOf9s's campaign file, so I will try to reproduce this when I get a chance and figure out where the problem is.

However, if you have a copy of the save file that stopped, please upload it. I am curious if they are all stopping in the reportLine section.
Reply
#5
I think it may result from using the new mass hire feature. At least it is pretty easy to get around that until it can be fixed if I'm right.
Reply
#6
Yes that is it. I will have a new release out by the end of next week, but until then don't hire using the multiple personnel option.
Reply
#7
Do you still want the file uploaded Taharqa? 

That's probably what happened on mine as before I finished yesterday I hired a bunch of people and saved. so that's probably same reason it did it t me.
Reply
#8
(12-06-2011, 01:36 PM)Taharqa link Wrote: Yes, I have JayOf9s's campaign file, so I will try to reproduce this when I get a chance and figure out where the problem is.

However, if you have a copy of the save file that stopped, please upload it. I am curious if they are all stopping in the reportLine section.

Sure, here it goes. Mine actually stopped in the middle of a mech.


Attached Files
.xml   3048Mercs.xml (Size: 24 KB / Downloads: 1)
Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Can't load/save your campaign? Taharqa 159 34,969 06-03-2019, 09:12 AM
Last Post: SilverSword
  Unable to Load Saved Campaign T.S. Hawk 10 2,198 01-06-2012, 01:40 PM
Last Post: T.S. Hawk
  Unable to bring up a saved campaign in version 1.11 saracen 5 1,404 12-31-2011, 12:24 PM
Last Post: Jayof9s
  Unable to load campaign with v0.1.10 DaddyHolby 14 3,048 12-07-2011, 12:03 AM
Last Post: DaddyHolby
  Can't Save Campaign Files to XML BATTLEMASTER 2 1,300 08-24-2011, 01:24 AM
Last Post: Tathas

Forum Jump:


Users browsing this thread: 1 Guest(s)