This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Default server configuration files?
#1
Hello everyone,

Does anyone know if it is possible to have a file with game defaults specified? I ask specifically because it can be annoying to have a server crash or hiccup and have to constantly re-set all of the related TacOps settings.

Besides, I'd kind of like to have a series of server-profiles that would allow for specific game types to be set by default.

Cheers,
-az

PS. I realize this subforum is probably more for links to dedicated servers rather than questions about them, but it seemed so underused and appropriate.
Reply
#2
I second this.  I just want to start a dedicated server from the command line in linux.  I know if I adjust the clientsettings.xml mmconf I can get the settings password but I'd like to have a password for the server.  Anyone?  Bueller? Bueller?
Reply
#3
Actually, I tried editing clientsettings.xml just to alter my initial colors but it doesn't work (closed app, didn't work).
Reply
#4
It looks like there is no command line for a password, although there probably should be. clientsettings.xml won't do anything to the server.
Reply
#5
I've been playing locally: how can I change the default camo?
Reply
#6
There is currently a bug that is causing clientsettings.xml to get overwritten with defaults on start up.

https://sourceforge.net/p/megamek/bugs/3072/

We will try to get that fixed for the stable.
Reply
#7
Bumping this old thread.

I'm using MegaMek version 0.37.11 (0.38.0 RC3) and I'm unable to find any configuration files at all.

I just want to add a password to my dedicated server, is there a way to specify a password via command line along with the port?

I've already tried -password to no avail. Sad
Reply
#8
When close the main MegaMekGUI, it will create the mmconf/clientsettings.xml file.  This file stores the port and password information that gets entered in the "Create a Server" dialog and if that information is present it gets used when creating a dedicated server. 

In [r10934] I added the ability to specify the password via the -password argument.  This should be in the next release candidate.
Reply
#9
Thank you very much, I'll look into it Smile
Reply
#10
I'd also like to note that the issue would've gotten attention sooner if there had been a ticket about it on SourceForge: threads get buried, but the ticketing system helps the devs determine what issues to work on.  This relates more to the -password argument.

There is [#3072] that Taharqa reported which is related to the settings files getting reset to defaults on Mac OS.  I actually have no idea what's going on with that bug and I can't reproduce it since I don't have a Mac OS machine to test on.
Reply
#11
(06-02-2014, 08:52 PM)Arlith link Wrote:In [r10934] I added the ability to specify the password via the -password argument.  This should be in the next release candidate.

I'm on 0.37.12 (0.38.0 RC4) and the -password argument is recognized but doesn't do anything Sad

When I connect to the game it just joins without asking me for a password.

Here's what the log says:

Code:
Starting MegaMek v0.37.12 ...
Compiled on Wed Dec 31 19:00:00 EST 1969
Today is Mon Jun 09 16:22:12 EDT 2014
Java vendor Oracle Corporation
Java version 1.7.0_55
Platform Linux 2.6.32-431.el6.x86_64 (amd64)
Total memory available to MegaMek: 1.013.632 kB

Starting Dedicated Server. args: [-port xxxx -password xxxx]
MMRandom: generating RNG type #1
s: starting a new server...
s: password = xxxx
s: listening for clients...
s: accepting player connection #0 ...

Am I doing something wrong?

Here's my startServer.sh script:

Code:
su megamek -c "nohup ./startup.sh -dedicated -port xxxx -password xxxx &"
Reply
#12
(06-09-2014, 04:30 PM)Romeo link Wrote:I'm on 0.37.12 (0.38.0 RC4) and the -password argument is recognized but doesn't do anything Sad

When I connect to the game it just joins without asking me for a password.

The password protects people from changing the game rules without the password.  It is not for restricting access to joining the game.  I think the assumption is that the IP and port are access control enough.
Reply
#13
ahhhhh ok, that makes sense!

Thanks for clarifying!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)