This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Campigan won't load
MegamekHQ will not open campaign file:

states out of memory.  I have attempted to *set* the memory at 2048m, 2G, several other options.

Currently the campaign file is 81 megs, running Windows 10, Java 8.

MMHQ 0.45.2

I *really* don't want to have lost this campaign file, since I'm trying to use MMHQ to help with a story I'm writing, and this campaign file is *well* into 3 weeks work...

(Campaign *would* load at 69 megs, file comes up apparently in Word and Excel.. but I *really* don't want to play with XML parsing.)


Edit to attach Log:
Attaching my log and *wtf'ing* at it.

I *do* not use those units..
Check to make sure your using 64 bit java.
That solved it, thank you very much.

Still got some odd errors in the log, but, it loaded.
(12-25-2018, 04:00 PM)MageOhki Wrote: That solved it, thank you very much.

Still got some odd errors in the log, but, it loaded.

If you open a ticket on our GitHub we can take a look at those exceptions in the log. You'll also find some performance enhancements in the next release that should help.
I'm going to. Performance is the problem.

I have two computers, both running the same MekHQ (.45.2)
Both running Win 10:

Differences: Desktop is i7-8700k, 16 gigs of RAM both 32 and 64 bit JAVA, 32 bit is 181, 64 bit is 191
Laptop: Pentium 3710, 4 gigs of ram, 191/191 Java (32/64). Both set at -Xmx8G
Opens the campaign file *decently* fast on the Desktop, and laptop gets laughed at.

Will open ticket, will include custom files, will include campaign file.
On the laptop your asking it to go to 8 gig of memory on a machine with 4 gig of memory. Try setting it to 1200k
Using -Xmx2G on the laptop was a no go, tried that several times. (Trying it on the desktop. It did work there)
1200 didn't try, but will when I use laptop again.
did try on the laptop. no joy.

Oh, oddity: On the *Laptop* at the load screen/choices box, it won't show the "Quit MegaMek HQ" button, Desktop it will.

Possibly Related Threads…
Thread Author Replies Views Last Post
  Option to load a savegame and load Princess instead of TestBot? Vashnevskaya 4 2,360 03-30-2013, 11:37 AM
Last Post: Netzilla

Forum Jump:

Users browsing this thread: 1 Guest(s)